Wikimaginot, le wiki de la ligne maginot



Incorrect


Fil ouvert par Zvon ( 71 ) - Posté le 27/02/2016

Hello,
I have a problém, I can not upload the photos. There is often message:

Warning: imagecreatefromjpeg(): gd-jpeg, libjpeg: recoverable error: Premature end of JPEG file in /home/wikimagi/public_html/_include/wiki_fonctions_inc.php on line 628

Warning: imagecreatefromjpeg(): '_documents/2016/_wiki_photos/330-1456565889.JPG' is not a valid JPEG file in /home/wikimagi/public_html/_include/wiki_fonctions_inc.php on line 628

Warning: imagecopyresampled() expects parameter 2 to be resource, boolean given in /home/wikimagi/public_html/_include/wiki_fonctions_inc.php on line 634

Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /home/wikimagi/public_html/_include/wiki_fonctions_inc.php on line 654

Warning: Cannot modify header information - headers already sent by (output started at /home/wikimagi/public_html/_include/wiki_fonctions_inc.php:628) in /home/wikimagi/public_html/photo_ajout.php on line 335


Is this problém on my side?

Sincerely
Michal


Réponse de Pascal ( 1507 ) - Posté le 27/02/2016
Dernière modification par Pascal le 27/02/2016.
Hello Zvon

A modification has been done to the the in charge of uploading and resizing pictures.
It has been tested but it seems that something went wrong.

In order to fix it, can you answer those questions :
- How many times did this happen ?
- Did all the messages come together with the same file ?

Regards, Pascal


Réponse de Zvon ( 71 ) - Posté le 27/02/2016

Hello Pascal,
it was probably six times or more, at different days. There were AP Revets and Mont Froid est last and this week. Today it was Poste de Turra.

Michal


Réponse de Zvon ( 71 ) - Posté le 27/02/2016

The incorrect upload is for example photo 42727

Michal


Réponse de jolasjm ( 2895 ) - Posté le 28/02/2016

Hello Michal

It seems that the problem is still ongoing, but in a random mode, which makes any diagnosis a bit difficult. One picture (the Plan à Marin telephone pole) has uploaded properly, but your picture of Mont Froid didn't. It is fully black as you can see on the site.

Amicalement
Jean-Michel


Réponse de Pascal ( 1507 ) - Posté le 29/02/2016
Dernière modification par Pascal le 29/02/2016.
Hello Zvon

As far as I could investigate, it seems that this problem occurs when due to an partial upload of a picture, an image stored on the server is corrupted. The scripts then can not cope with it and just echoes some warnings.

I have seen some black or partially black pictures here and there and , according to your answer and the information from Jean-Michel, I guess this was the illustration of the problem.

As the 'partial upload' is probably due to the network, I won't be able to solve it. I will jus modify the scripts in order to avoid those warnings that in fact are of no use for the public.

It means that a corrupted picture will still be displayed as a bad picture but without further notice. If this occurs , you will just have to upload it back, we will supress the 'bad' one.

Kind regards, Pascal


Réponse de Zvon ( 71 ) - Posté le 29/02/2016

OK, Jean-Michel and Pascal, many thanks. I try it
Michal


Vous ne pouvez pas participer à ce fil de discussion, seuls les membres peuvent y répondre ou y contribuer. S'inscrire est gratuit, rapide et sans engagement.